Hervorgehoben

Error: Package: php-phpmyadmin-sql-parser5-5.0.0-1.el7.remi.noarch (remi)

Regelmäßige Updates sorgen für eine fitale Servergesundheit. Aber was, wenn das Update unter

Vesta (0.9.8)

Centos (7.x)

mit dem Consolenbefehl

yum update -y

nicht funktioniert und folgende Fehlermeldungen erscheinen:

Error: Package: php-phpmyadmin-sql-parser5-5.0.0-1.el7.remi.noarch (remi)
Requires: php(language) >= 7.1
Removing: php-common-5.6.40-9.el7.remi.x86_64 (@remi-php56)
php(language) = 5.6.40
Updated By: php-common-5.6.40-13.el7.remi.x86_64 (remi-php56)
php(language) = 5.6.40
Available: php-common-5.4.16-46.el7.x86_64 (base)
php(language) = 5.4.16
Available: php-common-5.4.45-17.el7.remi.x86_64 (remi)
php(language) = 5.4.45
Available: php-common-5.5.38-10.el7.remi.x86_64 (remi-php55)
php(language) = 5.5.38
Available: php-common-5.5.38-11.el7.remi.x86_64 (remi-php55)
php(language) = 5.5.38
Available: php-common-5.6.40-12.el7.remi.x86_64 (remi-php56)
php(language) = 5.6.40
Error: Package: phpMyAdmin-5.0.0~alpha1-2.el7.remi.noarch (remi-test)
Requires: php(language) >= 7.1.3
Removing: php-common-5.6.40-9.el7.remi.x86_64 (@remi-php56)
php(language) = 5.6.40
Updated By: php-common-5.6.40-13.el7.remi.x86_64 (remi-php56)
php(language) = 5.6.40
Available: php-common-5.4.16-46.el7.x86_64 (base)
php(language) = 5.4.16
Available: php-common-5.4.45-17.el7.remi.x86_64 (remi)
php(language) = 5.4.45
Available: php-common-5.5.38-10.el7.remi.x86_64 (remi-php55)
php(language) = 5.5.38
Available: php-common-5.5.38-11.el7.remi.x86_64 (remi-php55)
php(language) = 5.5.38
Available: php-common-5.6.40-12.el7.remi.x86_64 (remi-php56)
php(language) = 5.6.40
Error: Package: php-twig2-2.11.3-1.el7.remi.noarch (remi)
Requires: php(language) >= 7.0
Removing: php-common-5.6.40-9.el7.remi.x86_64 (@remi-php56)
php(language) = 5.6.40
Updated By: php-common-5.6.40-13.el7.remi.x86_64 (remi-php56)
php(language) = 5.6.40
Available: php-common-5.4.16-46.el7.x86_64 (base)
php(language) = 5.4.16
Available: php-common-5.4.45-17.el7.remi.x86_64 (remi)
php(language) = 5.4.45
Available: php-common-5.5.38-10.el7.remi.x86_64 (remi-php55)
php(language) = 5.5.38
Available: php-common-5.5.38-11.el7.remi.x86_64 (remi-php55)
php(language) = 5.5.38
Available: php-common-5.6.40-12.el7.remi.x86_64 (remi-php56)
php(language) = 5.6.40
Error: Package: php-symfony4-common-4.1.13-1.el7.remi.noarch (remi)
Requires: php(language) >= 7.1.3
Removing: php-common-5.6.40-9.el7.remi.x86_64 (@remi-php56)
php(language) = 5.6.40
Updated By: php-common-5.6.40-13.el7.remi.x86_64 (remi-php56)
php(language) = 5.6.40
Available: php-common-5.4.16-46.el7.x86_64 (base)
php(language) = 5.4.16
Available: php-common-5.4.45-17.el7.remi.x86_64 (remi)
php(language) = 5.4.45
Available: php-common-5.5.38-10.el7.remi.x86_64 (remi-php55)
php(language) = 5.5.38
Available: php-common-5.5.38-11.el7.remi.x86_64 (remi-php55)
php(language) = 5.5.38
Available: php-common-5.6.40-12.el7.remi.x86_64 (remi-php56)
php(language) = 5.6.40
You could try using –skip-broken to work around the problem
You could try running: rpm -Va –nofiles –nodigest

Hier eine rasche Lösung, ohne auf die Hintergründe für diese Fehlermeldungen einzugehen:

nano /etc/yum.repos.d/remi.repo

Dort nach „remi-test“ suchen, steht gleich am Anfang und make enabled=1 auf

make enabled=0

setzen. Erneut das Update ausführen, „yum update -y“ – jetzt sollte es funktionieren,

SO: CentOS Linux release 7.7.1908 (Core) N 64 bits
kernel: 2.6.32-042stab138.1

(Abfrage, z.B. mit

wget –no-check-certificate https://github.com/rafa3d/vHWINFO/raw/master/vhwinfo.sh -O – -o /dev/null|bash

 

Mariya-Kobec-update-centos

Die Abbildung zeigt eine glückliche Mariya, nachdem das Centos Update funzte!
© Webverlag.net

 

 

 

 

Exim & [kthrotlds]

Das sind die aktuellen Herausforderungen:

  • Exim
    Beim beliebten Exim Mailprogramm gibt es ein Problem – ein offenes Scheunentor, daher wird dringend empfohlen, auf Version 4.92 aufzurüsten.

exim –version

Exim version 4.92 #3 built 05-Jun-2019 09:22:22

= bei diesem Ergebnis – alles OK, andernfalls

yum update -y

oder

yum update exim -y

 

 

 

aktuelle Probleme mit Serveradmin-Handlungsbedarf:
+ + + Exim – Update erforderlich + + +
+ + + Golang China Malware verbraucht alle Resourchen und lässt sich nicht stoppen: kthrotlds

 

 

 

Yum update -y klappt nicht?

Regelmäßiges update ist unverlässlich – doch was tun, wenn die Meldung kommt:

Error Summary
Disk Requirements: At least 11MB more space needed on the /boot filesystem.

Folgender Lösungsvorschlag:

To check the free space on /boot I ran the following command: df -h

Which gave the following output:

Filesystem Size Used Avail Use% Mounted on
/dev/vda3 136G 60G 70G 46% /
tmpfs 5.3G 0 5.3G 0% /dev/shm
/dev/vda1 99M 77M 17M 82% /boot
/usr/tmpDSK 1.3G 35M 1.2G 3% /tmp

As you can see the boot partition is 82% full.

To list installed kernels use this command:

rpm -qa | grep kernel

The result:

kernel-2.6.32-220.7.1.el6.x86_64
kernel-headers-2.6.32-358.2.1.el6.x86_64
dracut-kernel-004-303.el6.noarch
kernel-2.6.32-279.19.1.el6.x86_64
kernel-firmware-2.6.32-358.2.1.el6.noarch
kernel-2.6.32-279.9.1.el6.x86_64

So to remove the oldest kernel, I ran:

rpm -e kernel-2.6.32-220.7.1.el6.x86_64

Then: df -h

Output:

Filesystem Size Used Avail Use% Mounted on
/dev/vda3 136G 60G 70G 46% /
tmpfs 5.3G 0 5.3G 0% /dev/shm
/dev/vda1 99M 52M 42M 56% /boot
/usr/tmpDSK 1.3G 35M 1.2G 3% /tmp

As you can see that freed up more than the 11MB needed. So I retried yum -y update kernel and this time it works.

Quelle: